Autor Tema: Problemas con teléfono llave  (Leído 1746 veces)

  • Perfil
  • rover
  • Socio
  • Novato
  • *****
  •   2
    • Ver Perfil
« en: 03 de Abril de 2019, 12:24:09 pm »
Desde el primer día me ha pasado que el teléfono llave no funciona más que una vez. Siempre tengo que poner y quitar el modo avión, activar bluetooth y entonces va... hasta que dejo el coche. Luego siempre dice "Teléfono llave desconectado" y por mucho que intento de todo, solo va con el método poner modo avión/no avión/bluetooth... vamos, nada práctico.

El móvil es Motorola Moto G4, que sin ser de alta gama es un pepinaco de móvil (pantalla gigante, mucha memoria, etc). No me ha dado ningún problema con el Bluetooth de ningún coche, incluido el M3, funciona perfectamente, sincroniza llamadas, contactos y se oye de maravilla.
Obviamente, he mirado toda la configuración del móvil y no hay nada que pueda tocar, que yo haya visto, para hacerlo funcionar.

El caso es que he probado con otro móvil (Sony Xperia Z3 mini) que tenía por aquí con pantalla rota, problemas de la SIM que la lee cuando quiere, etc, pero lo que es bluetooth como Teléfono-llave funciona perfectamente, de lo que deduzco que es problema del Motorola y no del Model 3.

¿Tenéis experiencias al respecto y/o sabéis cómo solucionarlo? He escrito al SC de Madrid pero han pasado de mí totalmente.

¿Conocéis alguna lista de móviles que se sabe que funcionan o no?

Club Tesla España

Problemas con teléfono llave
« en: 03 de Abril de 2019, 12:24:09 pm »

« Respuesta #1 en: 03 de Abril de 2019, 01:05:13 pm »
Has probado borrar el emparejamiento entre coche y móvil y volver a empezar?

Sabes si tu móvil tiene el proceso de app en segundo plano? Es probable que la app del coche se desconecte al llevar un tiempo sin usarla y tengas que activar el segundo plano si el móvil puede

« Respuesta #2 en: 03 de Abril de 2019, 08:56:05 pm »
Mi mujer y yo estamos igual que tu Rover, amargados, porqué siempre que queremos acceder al M3, tenemos que ir con el móvil en la mano, activar la APP de Tesla, ver que se conecta a internet, ver si se sincroniza vía Bluetooth, aunque ponga el apartado "TELÉFONO LLAVE" "Conectado", la gran mayoría de veces no puedo abril el M3. Entonces me toca activar el modo avión y quitarlo, generalmente funciona, aparece "Conectado" y puedo abrir el M3, en ocasiones aunque ponga "Conectado" realmente no puedo acceder, entonces tengo que desactivar el Bluetooth, activarlo de nuevo. Una vez entro al M3 ya no tengo problemas, me reconoce la llave para conducirlo, los contactos del móvil activos, llamadas sin problemas y reproducción de MP3 a través del móvil sin problemas.

Tiene que ser alguna configuración de Android, pero no acierto a dar con la opción que corrija este problema. Tengo un móvil con Android 6.0 y mi mujer 7.0. He probado de configurar el móvil en el apartado de ajustes/batería y configurar la app de Tesla como "no optimizada" para que consuma lo que necesite; antes no la tenía así y el comportamiento era el mismo.

3000 Km gratis en Superchargers al comprar tu Tesla con este código:
franciscojavier76371

« Respuesta #3 en: 03 de Abril de 2019, 09:04:14 pm »
Muy buenas,

Pues otro igual, desesperado con el teléfono llave y el modo avión, nunca lo usé tanto. Yo he hecho de todo para que la aplicación no se quede en segundo plano ni ahorro de energía pero nada
Tengo un bq y Android 7, creo que le queda poco tiempo pq cualquier día sale volando hacia el suelo. Si alguien da con una solución se lo agradecería.

Un saludo.

« Respuesta #4 en: 03 de Abril de 2019, 11:53:00 pm »
Veo que no soy el único con este problema.
Al parecer debe ser problema del teléfono. Bueno mas que problema yo diría configuración de la app.
Android tiene por costumbre cerrar aplicaciones en segundo plano si no se le dice lo contrario.
Hay que configurar en el apartado de Batería, en ajustes, las apps que no quieres que se "optimizen".

Aquí un video donde se explica claramente como hacerlo:

Luego también procurar que el bluetooth esté siempre visible.
Probaré a ver si así se soluciona.
Éste es mi código de referido: https://ts.la/franciscojavier92275
No utilizar a menos que sea estrictamente necesario y os entren unas ganas locas de viajar en coche y merendar kilovatios a panes en los Superchargers 😋

  • Perfil
  • rover
  • Socio
  • Novato
  • *****
  •   2
    • Ver Perfil
« Respuesta #5 en: 04 de Abril de 2019, 09:01:27 am »
He probado todo lo que decís, borrar la app y volver a instalarla, quitar el enlace y volverlo a poner, "no optimizar" la app Tesla, pero nada, no hay manera. Y lo curioso es que el otro móvil (Sony Xperia Z3 compact) va perfecto, funciona siempre sin hacer nada.

El que no va es Android 7 y el que sí es 6, pero si Montigone dice que tampoco le funciona con un versión 6, pues tiene que ser otra cosa.

Sobre lo de hacer el móvil visible por bluetooth, tengo entendido que no es posible, solo está visible cuando abres la aplicación bluetooth para emparejar con otro dispositivo, y no he encontrado la forma de cambiarlo. Y yo creo que no es eso. El móvil que me funciona no está emparejado por bluetooth con el coche, por lo que entiendo que no se utiliza que estén emparejados... ¿o igual que lo estén es lo que lo estropea? no lo creo, entiendo que todo el mundo utiliza el manos libres del coche además del "teléfono-llave".

Lo que acabo de encontrar es que la aplicación "Bluetooth" está "optimizada" en batería... y si está dormida porque nadie la está usando (como cuando llegas al coche con el móvil en el bolsillo) tiene sentido que el coche no sea capaz de encontrar al móvil por bluetooth. Lo he desactivado y volveré a probar, pero la verdad es que tengo pocas esperanzas, porque en el móvil que funciona está sin tocar la configuración de "optimizar batería", con lo que entiendo que ambas apps Tesla y Bluetooth están optimizadas... o igual si no he tocado nada es que ¿ninguna está optimizada y por eso funciona?.

Bueno, yo seguiré investigando, si alguien descubre algo que por favor lo diga.

« Respuesta #6 en: 04 de Abril de 2019, 09:35:31 am »
Nada de nothing
Sigue sin funcionar.
He quitado incluso todo lo relacionado con el bluetooth de la optimización de bateria, pero sigue igual
Seguiré investigando
Éste es mi código de referido: https://ts.la/franciscojavier92275
No utilizar a menos que sea estrictamente necesario y os entren unas ganas locas de viajar en coche y merendar kilovatios a panes en los Superchargers 😋

« Respuesta #7 en: 04 de Abril de 2019, 12:26:37 pm »
La aplicación de Tesla para Android utiliza un servicio (una tarea que se está ejecutando de fondo) para controlar el acceso al coche mediante el móvil. Este servicio es de un tipo denominado "sticky" que hace que aunque Android cierre la aplicación, ya sea la actividad principal o el propio servicio, este volverá a ejecutarse nuevamente.
Lo ideal sería poder conectar el móvil a un ordenador y ejecutar la app en modo "debug" para ver cuál es la razón por la que falla, porque cada caso puede ser distinto.

Algunas posibles soluciones:
- Apagar y encender la conexión bluetooth
- Asegurarse de que no hay cerca otro teléfono registrado como llave
- Asegurarse de que el teléfono no está emparejado con otro dispositivo bluetooth (p.e.: un smart watch)
- Matar la app de Tesla desde el administrador de tareas y volverla a abrir
- Reiniciar el teléfono

« Respuesta #8 en: 04 de Abril de 2019, 02:08:45 pm »
La aplicación de Tesla para Android utiliza un servicio (una tarea que se está ejecutando de fondo) para controlar el acceso al coche mediante el móvil. Este servicio es de un tipo denominado "sticky" que hace que aunque Android cierre la aplicación, ya sea la actividad principal o el propio servicio, este volverá a ejecutarse nuevamente.
Lo ideal sería poder conectar el móvil a un ordenador y ejecutar la app en modo "debug" para ver cuál es la razón por la que falla, porque cada caso puede ser distinto.

Algunas posibles soluciones:
- Apagar y encender la conexión bluetooth
- Asegurarse de que no hay cerca otro teléfono registrado como llave
- Asegurarse de que el teléfono no está emparejado con otro dispositivo bluetooth (p.e.: un smart watch)
- Matar la app de Tesla desde el administrador de tareas y volverla a abrir
- Reiniciar el teléfono
- Cambiarse a un iPhone  ;)
You can use my referral code to get 1.500 km of free Supercharging on a new Tesla:
http://ts.la/joan65738

« Respuesta #9 en: 04 de Abril de 2019, 03:07:29 pm »
La aplicación de Tesla para Android utiliza un servicio (una tarea que se está ejecutando de fondo) para controlar el acceso al coche mediante el móvil. Este servicio es de un tipo denominado "sticky" que hace que aunque Android cierre la aplicación, ya sea la actividad principal o el propio servicio, este volverá a ejecutarse nuevamente.
Lo ideal sería poder conectar el móvil a un ordenador y ejecutar la app en modo "debug" para ver cuál es la razón por la que falla, porque cada caso puede ser distinto.

Algunas posibles soluciones:
- Apagar y encender la conexión bluetooth
- Asegurarse de que no hay cerca otro teléfono registrado como llave
- Asegurarse de que el teléfono no está emparejado con otro dispositivo bluetooth (p.e.: un smart watch)
- Matar la app de Tesla desde el administrador de tareas y volverla a abrir
- Reiniciar el teléfono
- Cambiarse a un iPhone  ;)

Esa tampoco parece ser la solución, ya que hay usuarios a los que también les falla teniendo un iPhone.  :P
Yo tengo un Android y solo me ha fallado una vez.

Lo ideal es que mejoren la app.

« Respuesta #10 en: 05 de Abril de 2019, 12:01:20 am »
En el foro de USA, hay hilos con los mismos fallos. Esta es una de las causas de que sacaran la llave después.

« Respuesta #11 en: 05 de Abril de 2019, 06:04:53 pm »
Hay otros aparatos cerca del coche por bluetooth ?


El Bluetooth a veces falla mas de lo k deberia
El mio actual con el coche a veces falla paro y aparco a un lado para evitar algun peligro...

Desconecto/conecto a veces va otras no y solucion en mi caso con el android k tengo anticuado v5.02...

Pues vuelvo a conectar el bluetooth y hacer una llamada perdida y voila ya funciona el travieso

Esto con mi querido y antiguo nokia nunca pasaba y ni hacia falta tener internet para ordenarle hacer llamadas mientras conduces...

« Respuesta #12 en: 05 de Abril de 2019, 07:41:44 pm »
La aplicación de Tesla para Android utiliza un servicio (una tarea que se está ejecutando de fondo) para controlar el acceso al coche mediante el móvil. Este servicio es de un tipo denominado "sticky" que hace que aunque Android cierre la aplicación, ya sea la actividad principal o el propio servicio, este volverá a ejecutarse nuevamente.
Lo ideal sería poder conectar el móvil a un ordenador y ejecutar la app en modo "debug" para ver cuál es la razón por la que falla, porque cada caso puede ser distinto.

Algunas posibles soluciones:
- Apagar y encender la conexión bluetooth
- Asegurarse de que no hay cerca otro teléfono registrado como llave
- Asegurarse de que el teléfono no está emparejado con otro dispositivo bluetooth (p.e.: un smart watch)
- Matar la app de Tesla desde el administrador de tareas y volverla a abrir
- Reiniciar el teléfono
- Cambiarse a un iPhone  ;)
+1



Enviado desde mi iPhone utilizando Tapatalk
You can use my referral code to get 1.500 km of free Supercharging on a new Tesla:
https://ts.la/franciscojos18419

« Respuesta #13 en: 08 de Abril de 2019, 11:11:48 pm »
Yo tengo un Samsung Galaxy Note 8 con Android 9 y el One UI y hasta ahora no he tenido problemas. Siempre voy con el bluetooth activado ya que tengo un smartwatch.

Sí que es cierto que aunque cierres la app, se te queda activada en la barra de Notificaciones y no se puede quitar (entiendo que se queda en segundo plano). Al principio me molestaba un poco, pero ya me he acostumbrado, además no he notado que eso provoque un consumo excesivo de la batería de mi móvil.

  • FurKen
  • Socio
  • Usuario Héroe
  • *****
  •   945
    • Ver Perfil
« Respuesta #14 en: 09 de Abril de 2019, 06:15:09 am »
0 problemas

OnePlus 5 ( Android 9 )

Aunque es verdad que a veces le cuesta 1 segundo abrir la puerta, le tengo que dar dos veces a la manilla de la puerta. Pero nada molesto. Vamos que OK
Si quieres usar mi código de referidos
https://ts.la/javier66032

Club Tesla España

Re:Problemas con teléfono llave
« Respuesta #14 en: 09 de Abril de 2019, 06:15:09 am »